<!DOCTYPE html>
<!--[if IE 8]> <html lang="en" class="no-js ie-browser lt-ie9"> <![endif]-->
<!--[if IE 9]> <html lang="en" class="no-js ie-browser ie9"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en" class="no-js"> <!--<![endif]-->
<head>

	<script>(function(H){H.className=H.className.replace(/\bno-js\b/,'js')})(document.documentElement)</script>

	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=Edge">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">

	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://usatodayhss.com/xmlrpc.php">

	
	<!--[if lt IE 9]>
    <script src="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/js/lib/html5.js" type="text/javascript"></script>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie8.css">
	<![endif]-->

	<!--[if gte IE 9]>
	<link rel="stylesheet" type="text/css" href="https://s0.wp.com/wp-content/themes/vip/usatoday-lawrence/ie9.css">
	<![endif]-->

	
	
<meta name="description" content="Brain tumor survivor Elochukwu Eze, blogs about his season, playing head-up against Zion Williamson, his unshakable faith and more." />
<meta name="keywords" content="athlete blogs, boys basketball, elochukwu eze, zion williamson" />
<title>The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more | USA TODAY High School Sports</title>
<meta name="google-site-verification" content="uI428cuhe5268Zph6gEQnbW5IrIBkccTlYCq_ezwW9g" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=usatodayhss.com&amp;id=65907669&amp;t=1517854795&amp;back=http%3A%2F%2Fusatodayhss.com%2F2018%2Fthe-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//native.sharethrough.com' />
<link rel='dns-prefetch' href='//mtrx.go.sonobi.com' />
<link rel='dns-prefetch' href='//usatodaysports-d.openx.net' />
<link rel='dns-prefetch' href='//js-sec.indexww.com' />
<link rel='dns-prefetch' href='//tags.tiqcdn.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//usathss.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="USA TODAY High School Sports &raquo; Feed" href="http://usatodayhss.com/feed" />
<link rel="alternate" type="application/rss+xml" title="USA TODAY High School Sports &raquo; Comments Feed" href="http://usatodayhss.com/comments/feed" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1516999477h&ver=4.9.3-RC1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJylkEFPwzAMhf8QIaoYExwQV+477OympvXqxFGdrvTfk60qaDCiSVyi9+L3OY7tFI2TkDAk60cTeWwpqJ2iE2/UE+P8w9071Tt7HWPqUe0BUwTXm7MrxZ0MmO99hHRKeGwIkNHnWAmbqGkxZVxXbRJ+FBEft+tDJ9nl8YqTLT+u6zigqsmnp9Gb1OXZfnPLtT1StKNCkgbmr0aayPWzocAU0BypQVkGv1a4qTPDNGBwuBb3oFDTP1D7ttvdsm4VR8CGcuTSLDDZIGkprqLUtUUxLA4SSbgw5p2BhhI6YM3SZtmeN/lt/1pCt7EtSw18Crz6l+qx2j5Vm+r54fAJ5GwhCw==?cssminify=yes' type='text/css' media='all' />
<script>var googletag_cmd_push = function(o){ return googletag.cmd.push( o ); };</script><script type='text/javascript'>
/* <![CDATA[ */
var amznAcctId = ["3090"];
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var prebidOptions = {"timeout":"500","prebid":[{"name":"_d_banner_flex","appnexus":7467616,"indexId":136,"indexSiteId":175937,"rubiconAccountId":10968,"rubiconSiteId":26280,"rubiconZoneId":450476},{"name":"_d_atf_flex","appnexus":7467644,"indexId":137,"indexSiteId":175938,"rubiconAccountId":10968,"rubiconSiteId":26280,"rubiconZoneId":450476},{"name":"_d_btf_flex","appnexus":7467672,"indexId":138,"indexSiteId":175939,"rubiconAccountId":10968,"rubiconSiteId":26280,"rubiconZoneId":450476},{"name":"_mw_320x50","appnexus":7467700,"indexId":139,"indexSiteId":175940,"rubiconAccountId":10968,"rubiconSiteId":33144,"rubiconZoneId":450520},{"name":"_mw_300x250","appnexus":7467730,"indexId":140,"indexSiteId":175941,"rubiconAccountId":10968,"rubiconSiteId":33144,"rubiconZoneId":450520}],"tablet":"","mobile":""};
/* ]]> */
</script>
<script type='text/javascript'>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");window.bidSlots=window.bidSlots||[];window._mweb=0;apstag.init({pubID: amznAcctId, adServer: "googletag"});
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJyVjt0KwjAMRl/Irmyi7kZ8lq6NM3X9MWk35tPbgV6IQxECgeR8J5FTFOj1kA2wtKVuGWh+tsryRn4DhMOeVILKoX/BOvgEPi2sCx0OIDIDqb7MiugcVrgYODlgLtDK9v0l9CPC9BOzkKLSV0HAeP+wpguUe3LEKDOrFIyaxaAmAq9hcXVoDJBwypeX6N90JCgC0ZTcyR3rXb1t2nbfHOwDudSIEA=='></script>
<script type='text/javascript' src='https://mtrx.go.sonobi.com/morpheus.usatoday.1587.js?ver=4.9.3-RC1'></script>
<script type='text/javascript' src='https://usatodaysports-d.openx.net/w/1.0/jstag?nc=7103-USA_RON&#038;ver=4.9.3-RC1'></script>
<script type='text/javascript' async src='https://js-sec.indexww.com/ht/p/184031-126856402220676.js?ver=4.9.3-RC1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var usatoday_gallery_ajax_object = {"publisherGA":"UA-49923927-1","sharethispubid":"fd7eb3e3-60ab-4eeb-9e7b-cb89e8ec8c83"};
var _usmgOptions = {"ipdir":"r","gaid":"UA-49923927-1","dfpid":"","pid":"HighSchoolSports","ads":[],"tlmurl":"http:\/\/tags.tiqcdn.com\/utag\/gci\/hss-media\/prod\/utag.js"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJylkNEOgjAMRX/I0QxCfDJ+S4WCHduYdAP5e0eiJr5BfGt6e07awhJUM/pIPkK8kyOBmQMkwTi2uKpgU89eAAOrHq2lifMIilAUMAKR0HJy72wtjJzgT2WSNuT+kiM166Lc47S4TOQb2ngZOCjLflDd2CRRHT+PKswjbcc4ZH8UtXz74BK5GXa95Gd9bqevIdeZv7qLrvW5qkutK/MCzHqjVw=='></script>
<script type='text/javascript'>
/* <![CDATA[ */
var utag_data = {"ssts":"sports:hss","priority_asset":"","blogname":"","videoincluded":"no","platform":"desktop","contenttype":"story pages","assetid":"101308543","headline":"The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more","byline":"Elochukwu Eze","taxonomykeywords":"boys basketball, Elochukwu Eze, Zion Williamson"};
/* ]]> */
</script>
<script type='text/javascript'>
					utag_data.clickPage = sessionStorage.getItem( "clickPage" );
					sessionStorage.setItem( "clickPage", window.location.href );
					
</script>
<script type='text/javascript' src='https://tags.tiqcdn.com/utag/gci/hss-media/prod/utag.js?ver=4.9.3-RC1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://usathss.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress.com" />
<link rel='shortlink' href='https://usat.ly/2nrPsw3' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=http%3A%2F%2Fusatodayhss.com%2F2018%2Fthe-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=http%3A%2F%2Fusatodayhss.com%2F2018%2Fthe-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more" />
<meta property="og:url" content="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more" />
<meta property="og:description" content="Brain tumor survivor Elochukwu Eze, blogs about his season, playing head-up against Zion Williamson, his unshakable faith and more." />
<meta property="article:published_time" content="2018-02-05T16:41:05+00:00" />
<meta property="article:modified_time" content="2018-02-05T16:41:05+00:00" />
<meta property="og:site_name" content="USA TODAY High School Sports" />
<meta property="og:image" content="https://usathss.files.wordpress.com/2016/06/ezblog.jpg?w=692&amp;h=450&amp;crop=1" />
<meta property="og:image:width" content="692" />
<meta property="og:image:height" content="450" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@usatodayhss" />
<meta name="twitter:text:title" content="The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more" />
<meta name="twitter:image:src" content="https://usathss.files.wordpress.com/2016/06/ezblog.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@USATODAYhss" />
<meta property="article:publisher" content="https://www.facebook.com/USATODAYHSS/" />
<link rel="shortcut icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/f703843d28767ce0e698bfc42b9e08f9?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="http://1.gravatar.com/blavatar/f703843d28767ce0e698bfc42b9e08f9?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="http://1.gravatar.com/blavatar/f703843d28767ce0e698bfc42b9e08f9?s=114" />
<link rel='openid.server' href='http://usathss.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='http://usathss.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="http://usatodayhss.com/osd.xml" title="USA TODAY High School Sports" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<style type="text/css">
.articleBody a,
.author__description a,
.search-no-results .entry-content a,
.archive-no-results .entry-content a,
.nav__item--parent > a:after,
.nav__item--podcast .nav__item-link,
.mobile-nav__item--podcast .mobile-nav__item-link,
.mobile-nav__footer-menu .mobile-nav__item a:active,
.trending__item:before,
.trending__link,
.hero__shares,
.column h3 > a:hover,
.second-tab-content p > a:hover,
.single-related p > a:hover,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block a:hover,
.widget--box .text-block a:hover,
.widget--section-promo p > a:hover,
.column .meta-info a,
.zone--video .medium .author a,
.block--hero .reply-block,
.social-cta__button,
.social-cta__notice--error,
#footer-info .togglee a:hover,
#footer-info .togglee a:active,
.article__subheading,
.articleBody h2,
.search-no-results .entry-content h2,
.archive-no-results .entry-content h2,
.article__author a,
.author__twitter a,
.articleBody .pq,
.search-no-results .entry-content .pq,
.archive-no-results .entry-content .pq,
.single-related .block__shares,
.widget--section-promo .block__shares,
.article__back:before,
.article__back:hover,
.archive .heading .taxonomy,
.search-results .heading .taxonomy,
.search-results .heading > span,
.archive.author .heading h1 a,
.widget_text .textwidget a,
.sidebar-upper .widget_usat_sidebar_top_posts_widget .text-block > h2,
.widget--box .text-block > h2,
.widget--author a,
.newsletter-close-alt a,
.related .block__title:hover,
.hero__secondary .hero__link:hover .hero__title {
	color: #eb1e00;
}

.mobile-stream-tabs h2,
.column .heading-small h2,
.sidebar-upper .widget .heading-small h2,
.single-related .heading-small h2,
#video-container .heading-small h2,
.mobile-stream-tabs > div {
	border-bottom-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding__logo-link {
		border-bottom-color: #eb1e00;
	}
}

.article__pagination .article__pagination__button:hover,
.article__pagination .article__pagination__link:hover,
.article__pagination .article__pagination__button:active,
.article__pagination .article__pagination__link:active {
	border-color: #eb1e00;
}

.nav__item:hover,
.nav__item--current,
#footer-info {
	border-top-color: #eb1e00;
}

.articleBody blockquote:not(.pq),
.search-no-results .entry-content blockquote:not(.pq),
.archive-no-results .entry-content blockquote:not(.pq) {
	border-left-color: #eb1e00;
}

.article__back,
.newsletter__input,
.daily-newsletter__input {
	border-color: #eb1e00;
}

.hero__label,
.column .block .img-holder .meta,
.second-tab-content h2,
.single-related .fixed-height-img-holder.link .meta,
.mobile-nav__menu .mobile-nav__item > a:active,
.mobile-nav__menu .mobile-nav__item--current > a,
.article__pagination__current,
.articleBody:after,
.search-no-results .entry-content:after,
.archive-no-results .entry-content:after,
.story-share-buttons .share-count,
.newsletter__button,
.daily-newsletter__button {
	background-color: #eb1e00;
}

.newsletter__button:after,
.daily-newsletter__button:after {
	background-color: #eb1e00;
}

@media all and (min-width: 1000px) {
	.branding {
		border-bottom-color: #eb1e00;
	}
}
</style>
<link rel="canonical" href="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more" />
		<style>
			.wpcom-related-posts ul li {
				list-style-type: none;
				display: inline-block;
			}
		</style>
		<meta name="application-name" content="USA TODAY High School Sports" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-task" content="name=Subscribe;action-uri=http://usatodayhss.com/feed;icon-uri=http://1.gravatar.com/blavatar/f703843d28767ce0e698bfc42b9e08f9?s=16" />
<!-- Include google_services.js -->
<script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
<script>
	var bottomAdMobileRendered = false,
		googletag = googletag || {},
		bidTimeout;
	googletag.cmd = googletag.cmd || [];
	bidManager.timeout = 2500;
	bidManager.addBidder('a9');
		bidManager.addBidSlot({ slotID: "videoSlot", mediaType : 'video' } );

	</script>
<!-- helper function for targeting the url -->
<script type='text/javascript'>
(function(e,t){function i(){e.googletag=e.googletag||{};e.sdpTargeting=this.urlTargeting();e._sitePage=e.sdpTargeting.sp}var n,r;i.prototype.urlTargeting=function(){var t=e.location.pathname.replace(/\/$/,""),n=new RegExp("/([^/]*)","ig"),r=t.match(n),i=["/"],s="";if(r&&t!=="/"){var o="",u=r.length;if(u>0){for(var a=0;a<u;a++){o=r[a];i.push(o);for(var f=a+1;f<u;f++){o+=r[f];i.push(o)}if(a===0){i.splice(-1,1);s=o}}}i.push(s)}i=i.reverse();var l=e.location.toString().replace(/\=/ig,":").match(/\?(.+)$/),c=RegExp.$1.split("&"),h=e.location.toString().replace(/\/*(\?|\&|\x26)*(\w+=\w+)*$/,"");var p=h.replace(/http:\/\//,"").split("/");var d=p.length==1?"main":p[1].match(/^$|^index\.(php|htm|html)+$/i)?"main":"general";return{title:h,targetPaths:i.slice(0,9),fullPath:i[0],queryStr:c,domainName:e.location.hostname,sp:d}};n=new i})(window,document)
</script>
<script type='text/javascript'>
if (typeof amznads !== "undefined") {
	var key = 'amznslots';
	var values = amznads.getTokens(); //comma separated
}
</script>
<script type='text/javascript'>
window.dfpTargetingObject = {"kw":["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"],"category":"Athlete Blogs","referrer":"","isMobile":"0"};
googletag_cmd_push(function() {
window.lawrence_dfp_desktop_skin = googletag.defineSlot("/7103/HighSchoolSports/skin/sports/preps/general", [1,1], "acm-ad-tag-lawrence_dfp_desktop_skin").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["skin"]);window.lawrence_dfp_desktop_interstitial = googletag.defineSlot("/7103/HighSchoolSports/interstitial/sports/preps/general", [2,1], "acm-ad-tag-lawrence_dfp_desktop_interstitial").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["interstitial"]);window.lawrence_dfp_desktop_sponsor_by_logo = googletag.defineSlot("/7103/HighSchoolSports/sponsor_logo/sports/preps/general", [[100,50]], "acm-ad-tag-lawrence_dfp_desktop_sponsor_by_logo").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["sponsor_logo"]);window.lawrence_dfp_desktop_top = googletag.defineSlot("/7103/HighSchoolSports/728x90_flex/sports/preps/general", ['fluid',[728,90],[970,66],[970,250]], "acm-ad-tag-lawrence_dfp_desktop_top").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["728x90_flex"]);window.lawrence_dfp_desktop_top_300x250 = googletag.defineSlot("/7103/HighSchoolSports/300x250_1a/sports/preps/general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_top_300x250").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_1a"]);window.lawrence_dfp_desktop_bottom_300x250 = googletag.defineSlot("/7103/HighSchoolSports/300x250_2a/sports/preps/general", [[300,250],[300,600]], "acm-ad-tag-lawrence_dfp_desktop_bottom_300x250").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["300x250_2a"]);window.lawrence_dfp_desktop_native = googletag.defineSlot("/7103/HighSchoolSports/native/sports/preps/general", [[640,170],[3,1]], "acm-ad-tag-lawrence_dfp_desktop_native").addService(googletag.pubads().setTargeting('kw',["boys basketball","Elochukwu Eze","Zion Williamson","Athlete Blogs"]).setTargeting('category',["Athlete Blogs"]).setTargeting("title", sdpTargeting.title).setTargeting("targetPaths", sdpTargeting.targetPaths).setTargeting("fullPath", sdpTargeting.fullPath).setTargeting("queryStr", sdpTargeting.queryStr).setTargeting("domainName", sdpTargeting.domainName) ).setTargeting("position", ["native"]);window.wasabiAsyncStickAd = false;
if ( ! window.hasOwnProperty( 'wasabiAsyncStickCallback' ) ) {
	window.wasabiAsyncStickCallback = function() {
		'use strict';
		window.wasabiAsyncStickAd = true;
	};
}
googletag.pubads().enableSingleRequest();

googletag.pubads().collapseEmptyDivs();
googletag.enableServices();

bidManager.initialize();
});
</script>
<link rel="amphtml" href="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more/amp" /><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s2.wp.com/?custom-css=1&#038;csblog=4sxAV&#038;cscache=6&#038;csrev=96" />
		
	<script type="text/javascript">
		var is_user_logged_in = 0;
	</script>

</head>

<body class="post-template-default single single-post postid-101308543 single-format-standard mp6 customizer-styles-applied highlander-enabled highlander-light">

	
	<div id='acm-ad-tag-lawrence_dfp_desktop_skin' style='width:1px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_skin'); });</script></div><div id='acm-ad-tag-lawrence_dfp_desktop_interstitial' style='width:2px; height:1px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_interstitial'); });</script></div>
	
<div id="wrapper">

	<div class="sticky-header-ad-above-nav-extra-space"></div>
<div id="header-ad" class="  header-ad--above-nav sticky-header-ad-above-nav">
	<div id='acm-ad-tag-lawrence_dfp_desktop_top' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top'); });</script></div></div>
<div class="sticky-header-ad-below-nav-extra-space"></div>

	<div class="wrapper-holder">

		<div
	class="branding "
	id="nav-branding"
>
	<span class="branding__logos">
					<a
				href="http://usatodayhss.com"
				title="USA TODAY High School Sports"
				class="branding__logo-link "
			>
				<img
					src="https://usathss.files.wordpress.com/2017/04/hss-logo.png"
					alt="USA TODAY High School Sports"
					class="branding__logo"
					height="30"
								>
			</a>
		
			</span>

	
	<span class="branding__search">
		<form method="get" class="branding__search-form" action="http://usatodayhss.com" role="search">
			<input type="text" name="s" value="" placeholder="search USA TODAY High School Sports" class="branding__search-input">
			<a class="branding__search-close"></a>
		</form>
	</span>

			<a class="branding__brand" href="http://usatodaysports.com" target="_blank" title="USA TODAY Sports">
			<img src="https://usathss.files.wordpress.com/2017/04/logo-usat-bar.png" alt="USA Today Sports" class="branding__brand-image" height="24">
		</a>
		<a class="branding__mobile"></a>
</div>
<header class="nav  ">
	<nav class="nav__wrap">
		<ul class="nav__menu">
			<li id="menu-item-723088" class="nav__item nav__item--home nav__item--parent"><a href="http://usatodayhss.com/">HOME</a>
<ul class="sub-menu">
	<li id="menu-item-723581" class="nav__item nav__item--usa-today-high-school-sports"><a href="http://launch.usatodayhss.com/">USA TODAY High School Sports</a></li>
	<li id="menu-item-100773066" class="nav__item nav__item--high-school-football-america"><a href="http://usatodayhss.com/category/high-school-football-america">High School Football America</a></li>
	<li id="menu-item-100769780" class="nav__item nav__item--texas-hs-football"><a href="http://usatodayhss.com/category/texas-hs-football">Texas HS Football</a></li>
	<li id="menu-item-100769779" class="nav__item nav__item--florida-hs-football"><a href="http://usatodayhss.com/category/florida-hs-football">Florida HS Football</a></li>
	<li id="menu-item-100769777" class="nav__item nav__item--gridiron-new-jersey"><a href="http://usatodayhss.com/category/gridiron-new-jersey">Gridiron New Jersey</a></li>
	<li id="menu-item-100769775" class="nav__item nav__item--prep-circuit"><a href="http://usatodayhss.com/category/prep-circuit">Prep Circuit</a></li>
</ul>
</li>
<li id="menu-item-100053735" class="nav__item nav__item--scores nav__item--parent"><a>Scores</a>
<ul class="sub-menu">
	<li id="menu-item-100915468" class="nav__item nav__item--national-basketball"><a href="http://usatodayhss.com/2016/scores-high-school-basketball-scores-around-the-nation">National - Basketball</a></li>
	<li id="menu-item-100915463" class="nav__item nav__item--super-25-boys-basketball"><a href="http://usatodayhss.com/2016/scores-high-school-basketball-super-25-boys-basketball-scoreboard">Super 25 - Boys Basketball</a></li>
	<li id="menu-item-100915465" class="nav__item nav__item--super-25-girls-basketball"><a href="http://usatodayhss.com/2016/scores-high-school-basketball-super-25-girls-basketball-scoreboard">Super 25 - Girls Basketball</a></li>
	<li id="menu-item-100333919" class="nav__item nav__item--super-25-football"><a href="http://usatodayhss.com/2017/scores-super-25-football-2">Super 25 - Football</a></li>
	<li id="menu-item-100333916" class="nav__item nav__item--national-football"><a href="http://usatodayhss.com/2017/scores-live-in-game-football-scores-around-the-nation-as-they-happen">National - Football</a></li>
	<li id="menu-item-101203876" class="nav__item nav__item--super-25-baseball"><a href="http://usatodayhss.com/2017/scores-super-25-baseball-2">Super 25 - Baseball</a></li>
</ul>
</li>
<li id="menu-item-679502" class="nav__item nav__item--features nav__item--parent"><a>Features</a>
<ul class="sub-menu">
	<li id="menu-item-100518460" class="nav__item nav__item--mcdonalds-all-american-games"><a href="http://usatodayhss.com/category/mcdonalds-all-american-game">McDonald's All American Games</a></li>
	<li id="menu-item-101238685" class="nav__item nav__item--score-predictor"><a href="http://usatodayhss.com/score-predictor">Score Predictor</a></li>
	<li id="menu-item-849725" class="nav__item nav__item--all-usa"><a href="http://usatodayhss.com/category/all-usa">ALL-USA</a></li>
	<li id="menu-item-768922" class="nav__item nav__item--super-25"><a href="http://usatodayhss.com/category/super-25">Super 25</a></li>
	<li id="menu-item-101307050" class="nav__item nav__item--hoophall-classic"><a href="http://usatodayhss.com/category/hoophall-classic">Hoophall Classic</a></li>
	<li id="menu-item-988528" class="nav__item nav__item--u-s-army-all-american-bowl"><a href="http://usatodayhss.com/category/u-s-army-all-american-bowl">U.S. Army All-American Bowl</a></li>
	<li id="menu-item-988529" class="nav__item nav__item--under-armour-all-america-game"><a href="http://usatodayhss.com/category/under-armour-all-america-game">Under Armour All-America Game</a></li>
	<li id="menu-item-101253776" class="nav__item nav__item--early-signing-period"><a href="http://usatodayhss.com/category/early-signing-period">Early Signing Period</a></li>
	<li id="menu-item-100518463" class="nav__item nav__item--jordan-brand-classic"><a href="http://usatodayhss.com/category/jordan-brand-classic">Jordan Brand Classic</a></li>
	<li id="menu-item-100073770" class="nav__item nav__item--national-signing-day"><a href="http://usatodayhss.com/category/signing-day">National Signing Day</a></li>
	<li id="menu-item-100915316" class="nav__item nav__item--nata-sports-safety"><a href="http://usatodayhss.com/tag/nata">NATA Sports Safety</a></li>
	<li id="menu-item-990005" class="nav__item nav__item--achieving-the-dream"><a href="http://usatodayhss.com/category/video/achieving-the-dream/">Achieving The Dream</a></li>
	<li id="menu-item-100510295" class="nav__item nav__item--spalding-hoophall-classic"><a href="http://usatodayhss.com/category/hoophall-classic">Spalding Hoophall Classic</a></li>
	<li id="menu-item-679503" class="nav__item nav__item--celeb-chop-up"><a href="http://usatodayhss.com/category/celeb-chop-up">Celeb Chop-Up</a></li>
	<li id="menu-item-679504" class="nav__item nav__item--athlete-look-back"><a href="http://usatodayhss.com/category/athlete-look-back">Athlete Look Back</a></li>
	<li id="menu-item-100587897" class="nav__item nav__item--girls-sports-month"><a href="http://www.usatodayhss.com/category/girls-sports-month">Girls Sports Month</a></li>
</ul>
</li>
<li id="menu-item-723109" class="nav__item nav__item--blogs nav__item--parent"><a>Blogs</a>
<ul class="sub-menu">
	<li id="menu-item-100518416" class="nav__item nav__item--mcdonalds-all-american-game-hometown-heroes"><a href="http://usatodayhss.com/category/mcdonalds-all-american-game-selection-tour">McDonald's All American Game Hometown Heroes</a></li>
	<li id="menu-item-988531" class="nav__item nav__item--under-armour-all-america-selection-tour"><a href="http://usatodayhss.com/category/under-armour-all-america-selection-tour">Under Armour All-America Selection Tour</a></li>
	<li id="menu-item-988538" class="nav__item nav__item--u-s-army-all-american-selection-tour"><a href="http://usatodayhss.com/category/u-s-army-all-american-bowl-selection-tour">U.S. Army All-American Selection Tour</a></li>
	<li id="menu-item-100296970" class="nav__item nav__item--outside-the-box"><a href="http://usatodayhss.com/category/outside-the-box">Outside The Box</a></li>
	<li id="menu-item-100159012" class="nav__item nav__item--recruiting"><a href="http://www.usatodayhss.com/tag/recruiting-2">Recruiting</a></li>
	<li id="menu-item-768927" class="nav__item nav__item--athlete-blogs"><a href="http://usatodayhss.com/category/athlete-blogs">Athlete Blogs</a></li>
</ul>
</li>
<li id="menu-item-916553" class="nav__item nav__item--rankings nav__item--parent"><a>Rankings</a>
<ul class="sub-menu">
	<li id="menu-item-101250681" class="nav__item nav__item--boys-basketball-expert"><a href="http://usatodayhss.com/rankings/expert/boys/basketball/2017/10">Boys Basketball - Expert</a></li>
	<li id="menu-item-101250682" class="nav__item nav__item--boys-basketball-computer"><a href="http://usatodayhss.com/rankings/computer/boys/basketball/US/2017">Boys Basketball - Computer</a></li>
	<li id="menu-item-101250743" class="nav__item nav__item--girls-basketball-expert"><a href="http://usatodayhss.com/rankings/expert/girls/basketball/2017/9">Girls Basketball - Expert</a></li>
	<li id="menu-item-101250866" class="nav__item nav__item--girls-basketball-computer"><a href="http://usatodayhss.com/rankings/computer/girls/basketball/US/2017">Girls Basketball - Computer</a></li>
	<li id="menu-item-101250219" class="nav__item nav__item--wrestling"><a href="http://usatodayhss.com/rankings/expert/boys/wrestling/2017/4">Wrestling</a></li>
	<li id="menu-item-101267273" class="nav__item nav__item--boys-soccer-winter"><a href="http://usatodayhss.com/rankings/expert/boys/winter-soccer/2017/3">Boys Soccer - Winter</a></li>
	<li id="menu-item-101267366" class="nav__item nav__item--girls-soccer-winter"><a href="http://usatodayhss.com/rankings/expert/girls/winter-soccer/2017/3">Girls Soccer - Winter</a></li>
	<li id="menu-item-101237000" class="nav__item nav__item--football-expert"><a href="http://usatodayhss.com/rankings/expert/boys/football/2017/20">Football - Expert</a></li>
	<li id="menu-item-101236999" class="nav__item nav__item--football-computer"><a href="http://usatodayhss.com/rankings/computer/boys/football/US/2017">Football - Computer</a></li>
	<li id="menu-item-101238829" class="nav__item nav__item--boys-soccer-fall"><a href="http://usatodayhss.com/rankings/expert/boys/fall-soccer/2017/14">Boys Soccer - Fall</a></li>
	<li id="menu-item-101238728" class="nav__item nav__item--girls-soccer-fall"><a href="http://usatodayhss.com/rankings/expert/girls/fall-soccer/2017/14">Girls Soccer - Fall</a></li>
	<li id="menu-item-101239155" class="nav__item nav__item--girls-volleyball"><a href="http://usatodayhss.com/rankings/expert/girls/volleyball/2017/12">Girls Volleyball</a></li>
</ul>
</li>
<li id="menu-item-723201" class="nav__item nav__item--video-photos nav__item--parent"><a href="#">Video/Photos</a>
<ul class="sub-menu">
	<li id="menu-item-768928" class="nav__item nav__item--video"><a href="http://usatodayhss.com/category/video">Video</a></li>
	<li id="menu-item-100416643" class="nav__item nav__item--photos"><a href="http://usatodayhss.com/category/photos">Photos</a></li>
</ul>
</li>
<li id="menu-item-101246054" class="nav__item nav__item--polls"><a href="http://usatodayhss.com/category/polls">Polls</a></li>
<li id="menu-item-723108" class="nav__item nav__item--store"><a href="http://spiritshop.com/hssschoolsearch.aspx?utm_source=hss&#038;utm_medium=partner&#038;utm_campaign=hss-nav&#038;utm_term=header_nav_link">Store</a></li>
		</ul>
		<ul class="nav__social ">
							<li class="nav__item nav__item--social nav__item--facebook">
					<a href="https://www.facebook.com/USATODAYHSS/" class="nav__item-link"></a>
				</li>
							<li class="nav__item nav__item--social nav__item--twitter">
					<a href="https://twitter.com/usatodayhss" class="nav__item-link"></a>
				</li>
					</ul>
	</nav>
</header>

		
		
		<div id="main" class="site-main ">

			

<div id="primary" class="content-area">
	<div id="content" class="site-content" role="main">

		
		
			<article id="post-101308543" class="post-101308543 post type-post status-publish format-standard has-post-thumbnail hentry category-athlete-blogs tag-boys-basketball tag-elochukwu-eze tag-zion-williamson article--no-image" itemscope itemtype="http://schema.org/NewsArticle">

				<div class="article__title article__title--no-image ">
	<h1 class="article__headline">The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more</h1>

	</div>
<h1 class="article__headline article__headline--mobile">The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more</h1>

				<header class="entry-header  ">

					
<h2 class="">
	<a href="http://usatodayhss.com/category/athlete-blogs" class="" itemprop="articleSection">Athlete Blogs</a></h2>

					
					<div id="headline">
						<h1 class="entry-title" itemprop="name headline">The Elochukwu Eze Blog: New school, battling Zion Williamson, faith and more</h1>
											</div>

					
					
					<div class="meta-info single-headline" id="entry-byline">
						
<p itemprop="author" itemscope itemtype="http://schema.org/Person">

	By <a href="http://usatodayhss.com/author/elochukwu-eze" title="Posts by Elochukwu Eze" class="author url fn" rel="author">Elochukwu Eze</a> 
		<span class="post-date updated">February 5, 2018</span>

	
	</p>
					</div>

					<div id='acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_mobile_sponsor_by_logo'); });</script></div>
				</header>

				
				
				
				<div id="content-container">
					<div class="entry-content normal-format">

						
						<div class="story-share-buttons no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count"></span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="usatodayhss"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
			data-short-url="https://usat.ly/2nrPsw3"
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>

						
						<div class="article__author">
	<p itemprop="author" itemscope itemtype="http://schema.org/Person">
		By: <a href="http://usatodayhss.com/author/elochukwu-eze" title="Posts by Elochukwu Eze" class="author url fn" rel="author">Elochukwu Eze</a>		| February 5, 2018		<span class="article__author__widgets">
								</span>
	</p>

	</div>


						
						<div class="articleBody" itemprop="articleBody"><p><em>On May 4, Elochukwu Eze, a 6-foot-10 center at Asheville Christian Academy (N.C.) who is drawing interest from a handful of Division I colleges, was diagnosed with a fist-sized brain tumor and had to undergo emergency surgery. Eze has agreed to give USA Today High Schools Sports exclusive access into his road to recovery by chronicling his thoughts and experiences in a blog. </em></p>
<p>Hey everybody, it has been a wild year for me!</p>
<p>Hope you all are well.</p>
<p>As you probably know, I transferred from Calvary Christian Academy in Ft. Lauderdale, Fla., (where I won a state championship last year) to Asheville Christian Academy in North Carolina.</p>
<p>I loved my teammates and coaches at Calvary, but when we returned from Las Vegas in early August my dad was told his position had been eliminated. It was a shock to him and to me.</p>
<p>Eight weeks later, on September 30th, my siblings and I left the only house we knew (me in the U.S.) and moved to Asheville.</p>
<p>So here I am in my senior year and I am transferring away from a state championship team.</p>
<p>It was tough – I’m not gonna lie!</p>
<p>But I have to admit that I like Asheville and love my new team and coaches at ACA.</p>
<p>Sure, I miss Coach Cilk, Coach Steve, Solomon, Tim, DJ and others – but I must say that Coach Ray, Caleb, Justin, Ray, Max and my teammates have made this a much better transition than I expected.</p>
<p>We have a chance to be something special!</p>
<div class="embed-twitter">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">ACA improves to 14-7 tonight with a win over Carolina Day. Congratulations to <a href="https://twitter.com/Eze_BigE23?ref_src=twsrc%5Etfw">@Eze_BigE23</a> Elochukwu Eze, for being selected to play in the NCISAA All Str game in Charlotte on March 3rd. Go Big E! <a href="https://t.co/aevCDyhqTC">pic.twitter.com/aevCDyhqTC</a></p>
<p>&mdash; Geoff Still (@GeoffStill1) <a href="https://twitter.com/GeoffStill1/status/957088987495120897?ref_src=twsrc%5Etfw">January 27, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div>
<p>We definitely play tough competition up here and I love that. Our team is working hard and getting better every week. We are now 15-7 and getting ready to play Asheville School on Friday.</p>
<p>I have played some tough talent since I started playing basketball, but I must admit that Zion Williamson is a great player and brought his game to us.</p>
<p>I am not going to back down on defense. He got us for 31 and the win but I didn’t give up and as he tried to throw one down in the 4th quarter I met him at the rim and rejected his dunk. It was my third big block of a dunk attempt this year.</p>
<div class="embed-twitter">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true">
<p lang="en" dir="ltr">Has Zion ever been blocked before? 👀 <a href="https://t.co/fqxBudZXyl">pic.twitter.com/fqxBudZXyl</a></p>
<p>&mdash; Overtime (@overtime) <a href="https://twitter.com/overtime/status/951632726104399873?ref_src=twsrc%5Etfw">January 12, 2018</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div>
<p>I promise you – I am going to do all I can to be a rim protector and I will block the dunk attempts of the best of them.</p>
<p>It’s been a wild time of a recruiting process.  I know that having the brain tumor set me back some but I am not using it as an excuse.  I have overcome more than anybody would ever want to imagine and I am coming out fighting. I promise you that the coach that signs me will get everything they want in a 5 man and more.</p>
<p>Since I have moved to N.C. I have about 10 mid-major schools that have been talking to me.  On Saturday I took an unofficial visit to Appalachian State.  We also were on campus for an unofficial visit with Radford University and I have talked to several other coaches about coming to visit them on campus too.  I have a couple of schools that are talking to me now about taking an official visit.</p>
<p>I’ve also been selected for the NCISAA All Star game in Charlotte, NC on March 3rd.  I am honored to hear that they selected me for this.  I am going to keep working hard and continue to raise my game.</p>
<p>Anyway, I have shared Jeremiah 29:11 since my surgery, where God says “I know the plans I have for you, to prosper you and not to hurt you…” and I would say that through all of my journey this has been the case.</p>
<p>It hasn’t been easy – but I would say that God has been in the forefront and we are better off than we were because of God’s control.  I encourage you to seek him.  If I can be of any help to you, reach out and let me know.</p>
<p><strong>Don’t forget to follow </strong><strong>Elochukwu Eze:</strong></p>
<p>T<strong>witter:</strong> @Eze_BigE23</p>
<p><strong>Instagram:</strong> @b_e_e_e_z_e</p>
</div>

						
						
						<p class="post-tags post-tags--hide"><a href="http://usatodayhss.com/tag/boys-basketball" rel="tag">boys basketball</a>, <a href="http://usatodayhss.com/tag/elochukwu-eze" rel="tag">Elochukwu Eze</a>, <a href="http://usatodayhss.com/tag/zion-williamson" rel="tag">Zion Williamson</a>, <a href="http://usatodayhss.com/category/athlete-blogs" rel="category tag">Athlete Blogs</a></p>
						<div class="story-share-buttons no-share-count fullwidth">
	<div class="share-button share-count">
		<span class="icomoon icon-shares"></span>
		<span class="count"></span>
		<span class="share-text">shares</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storyfb"
		class="share-button share-facebook st-custom-button"
		id="share-facebook"
		data-network="facebook"
	>
		<span class="icomoon icon-facebook"></span>
		<span class="share-text">share</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storytwitter"
		class="share-button share-twitter st-custom-button"
		id="share-twitter"
		data-network="twitter"
		data-username="usatodayhss"
	>
		<span class="icomoon icon-twitter"></span>
		<span class="share-text">tweet</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storypinterest"
		class="share-button share-pinterest st-custom-button"
		id="share-pinterest"
		data-network="pinterest"
		data-username=""
	>
		<span class="icomoon icon-pinterest"></span>
		<span class="share-text">pin</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storysms"
		class="share-button share-sms st-custom-button"
		id="share-sms"
		data-network="sms"
	>
		<span class="icomoon icon-sms"></span>
		<span class="share-text">sms</span>
	</div>
	<div
		data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
		data-short-url="https://usat.ly/2nrPsw3"
		data-track="storywhatsapp"
		class="share-button share-whatsapp st-custom-button"
		id="share-whatsapp"
		data-network="whatsapp"
	>
		<span class="icomoon icon-whatsapp"></span>
		<span class="share-text">send</span>
	</div>

			<div
			data-url="http://usatodayhss.com/2018/the-elochukwu-eze-blog-new-school-battling-zion-williamson-faith-and-more"
			data-short-url="https://usat.ly/2nrPsw3"
			data-track="storyemail"
			class="share-button share-email st-custom-button"
			id="share-email"
			data-network="email"
			data-message=""
		>
				<span class="icomoon icon-email"></span>
			<span class="share-text">email</span>
		</div>
</div>
					</div><!-- .entry-content -->
				</div><!-- #content-container -->

				
			</article><!-- #post-## -->

		
		<div class="container divider"></div>
<div class="container single-related">

		<div class="heading-small">
		<h2>Related <span>News</span></h2>
	</div>
	
	<div class="holder-column">
		<div class="column">
			<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://usatodayhss.com/2018/zion-williamson-electrifies-crowd-dunks"
	   data-track="featuredstories more-related-1"
	   title="Watch Zion Williamson&#039;s electrifying 45-point performance"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathss.files.wordpress.com/2018/01/spartanburg-day-vs-spartanburg-chirstian-1-26-18.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathss.files.wordpress.com/2018/01/spartanburg-day-vs-spartanburg-chirstian-1-26-18.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Watch Zion Williamson&#039;s electrifying 45-point performance" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

		<img class="play-overlay" src="https://s1.wp.com/wp-content/themes/vip/usatoday-plugins/wasabi//images/video.svg" alt="Watch Zion Williamson&#039;s electrifying 45-point performance">	</a>

	<div class="text-block">

		<span class="block__shares">22 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="http://usatodayhss.com/category/video" class="category" itemprop="articleSection">Video</a></h2>

		<p>
			<a data-track="featuredstories more-related-1" href="http://usatodayhss.com/2018/zion-williamson-electrifies-crowd-dunks"
			   title="Watch Zion Williamson&#039;s electrifying 45-point performance" itemprop="url">
				Watch Zion Williamson's electrifying 45-point performance			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://usatodayhss.com/2018/the-r-j-barrett-blog-zion-williamson-duke-mike-krzyzewski-drake-gods-plan-mcdonalds"
	   data-track="featuredstories more-related-2"
	   title="The R.J. Barrett Blog: Making McDonald&#039;s Game, crazy travel schedule, Zion Williamson and more"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathss.files.wordpress.com/2017/05/rj_barrett.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathss.files.wordpress.com/2017/05/rj_barrett.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="The R.J. Barrett Blog: Making McDonald&#039;s Game, crazy travel schedule, Zion Williamson and more" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

			</a>

	<div class="text-block">

		<span class="block__shares">442 shares</span><span class="block__time block__time--mobile">2w ago</span>
		<h2><a href="http://usatodayhss.com/category/athlete-blogs" class="category" itemprop="articleSection">Athlete Blogs</a></h2>

		<p>
			<a data-track="featuredstories more-related-2" href="http://usatodayhss.com/2018/the-r-j-barrett-blog-zion-williamson-duke-mike-krzyzewski-drake-gods-plan-mcdonalds"
			   title="The R.J. Barrett Blog: Making McDonald&#039;s Game, crazy travel schedule, Zion Williamson and more" itemprop="url">
				The R.J. Barrett Blog: Making McDonald's Game, crazy travel schedule, Zion Williamson and more			</a>
		</p>

	</div>
</article>
<article class="block block-single-related" itemscope itemtype="http://schema.org/NewsArticle">
	<a href="http://usatodayhss.com/2018/onyeka-okongwu-stars-chino-hills-zion-williamson"
	   data-track="featuredstories more-related-3"
	   title="Replacing Ball family, Chino Hills’ Onyeka Okongwu stars on big stage"
	   class="link fixed-height-img-holder responsiveshort"
	   rel="nofollow"
					style="background-image: url('https://usathss.files.wordpress.com/2018/01/ax207_3d79_9.jpg?w=295&#038;h=231&#038;crop=1');"
			   itemprop="url">

					<img src="https://usathss.files.wordpress.com/2018/01/ax207_3d79_9.jpg?w=295&#038;h=231&#038;crop=1" width="206" height="165" alt="Replacing Ball family, Chino Hills’ Onyeka Okongwu stars on big stage" itemprop="image">
		
		<span class="ie-overlay-hack"></span>

			</a>

	<div class="text-block">

		<span class="block__shares">208 shares</span><span class="block__time block__time--mobile">4w ago</span>
		<h2><a href="http://usatodayhss.com/category/hoophall-classic" class="category" itemprop="articleSection">Hoophall Classic</a></h2>

		<p>
			<a data-track="featuredstories more-related-3" href="http://usatodayhss.com/2018/onyeka-okongwu-stars-chino-hills-zion-williamson"
			   title="Replacing Ball family, Chino Hills’ Onyeka Okongwu stars on big stage" itemprop="url">
				Replacing Ball family, Chino Hills’ Onyeka Okongwu stars on big stage			</a>
		</p>

	</div>
</article>

		</div>
	</div>
</div>
<div class="container column container--stories">
	<div class="heading-small">
		<h2>Latest</h2>
	</div>
	<div id='acm-ad-tag-lawrence_dfp_desktop_native' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_native'); });</script></div>
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/recruiting-tip-the-top-five-college-recruiting-tips-of-all-time"
						title="Recruiting Tip: The top five college recruiting tips of all time"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/recol2518.png?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/recol2518.png?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Recruiting Tip: The top five college recruiting tips of all time" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

									</div>

			
			<div class="mobile-date">
				51m			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/recruiting-tip-the-top-five-college-recruiting-tips-of-all-time"
						title="Recruiting Tip: The top five college recruiting tips of all time"
						itemprop="url" 						>
							Recruiting Tip: The top five college recruiting tips of all time					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/fred-bastie-playced-com" title="Posts by Fred Bastie, Playced.com" class="author url fn" rel="author">Fred Bastie, Playced.com</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/nunzio-campanile-coach-rutgers"
						title="Nunzio Campanile leaving N.J. football power Bergen Catholic for Rutgers"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/bc1.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/bc1.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Nunzio Campanile leaving N.J. football power Bergen Catholic for Rutgers" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/nunzio-campanile-coach-rutgers"
						title="Nunzio Campanile leaving N.J. football power Bergen Catholic for Rutgers"
						itemprop="url" 						>
							Nunzio Campanile leaving N.J. football power Bergen Catholic for Rutgers					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/darren-cooper-northjersey-com" title="Posts by Darren Cooper, NorthJersey.com" class="author url fn" rel="author">Darren Cooper, NorthJersey.com</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/video-this-one-handed-7v7-snag-was-better-than-any-catch-in-the-super-bowl"
						title="VIDEO: This one-handed 7v7 snag was better than any catch in the Super Bowl"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/screen-shot-2018-02-04-at-11-31-53-pm.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/screen-shot-2018-02-04-at-11-31-53-pm.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="VIDEO: This one-handed 7v7 snag was better than any catch in the Super Bowl" itemprop="image">
						<span class="ie-overlay-hack"></span>

						<img class="play-overlay" src="https://s1.wp.com/wp-content/themes/vip/usatoday-plugins/wasabi//images/video.svg" alt="VIDEO: This one-handed 7v7 snag was better than any catch in the Super Bowl">
											</a>

									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/video-this-one-handed-7v7-snag-was-better-than-any-catch-in-the-super-bowl"
						title="VIDEO: This one-handed 7v7 snag was better than any catch in the Super Bowl"
						itemprop="url" 						>
							VIDEO: This one-handed 7v7 snag was better than any catch in the Super Bowl					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/camasmith" title="Posts by Cam Smith, USA TODAY High School Sports" class="author url fn" rel="author">Cam Smith, USA TODAY High School Sports</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/motivation-monday-vanderbilt-signee-simi-shittu-dishes-on-what-fuels-his-fire"
						title="Motivation Monday: Vanderbilt signee Simi Shittu dishes on what fuels his fire"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/01/20180123_133308-e1517810763130.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/01/20180123_133308-e1517810763130.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Motivation Monday: Vanderbilt signee Simi Shittu dishes on what fuels his fire" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/motivation-monday-vanderbilt-signee-simi-shittu-dishes-on-what-fuels-his-fire"
						title="Motivation Monday: Vanderbilt signee Simi Shittu dishes on what fuels his fire"
						itemprop="url" 						>
							Motivation Monday: Vanderbilt signee Simi Shittu dishes on what fuels his fire					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/jcjordan2014" title="Posts by Jason Jordan, USA Today High School Sports" class="author url fn" rel="author">Jason Jordan, USA Today High School Sports</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/sunrise-christian-climbs-to-no-5-with-two-big-wins"
						title="Sunrise Christian climbs to No. 5 with two big wins"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/dante.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/dante.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Sunrise Christian climbs to No. 5 with two big wins" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='http://usatodayhss.com/2018/sunrise-christian-climbs-to-no-5-with-two-big-wins';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://usatodayhss.com/2018/sunrise-christian-climbs-to-no-5-with-two-big-wins"
			title="Sunrise Christian climbs to No. 5 with two big wins"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>25</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				1hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/sunrise-christian-climbs-to-no-5-with-two-big-wins"
						title="Sunrise Christian climbs to No. 5 with two big wins"
						itemprop="url" 						>
							Sunrise Christian climbs to No. 5 with two big wins					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/jimhalley55" title="Posts by Jim Halley, USA TODAY High School Sports" class="author url fn" rel="author">Jim Halley, USA TODAY High School Sports</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/poll-vote-for-the-top-all-usa-boys-basketball-point-guard-of-all-time"
						title="POLL: Vote for the top ALL-USA Boys Basketball Point Guard of all-time"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/kyrie-irving-michael-dwyer-ap.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/kyrie-irving-michael-dwyer-ap.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="POLL: Vote for the top ALL-USA Boys Basketball Point Guard of all-time" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

									</div>

			
			<div class="mobile-date">
				3hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/poll-vote-for-the-top-all-usa-boys-basketball-point-guard-of-all-time"
						title="POLL: Vote for the top ALL-USA Boys Basketball Point Guard of all-time"
						itemprop="url" 						>
							POLL: Vote for the top ALL-USA Boys Basketball Point Guard of all-time					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/davescott928" title="Posts by USA TODAY High School Sports" class="author url fn" rel="author">USA TODAY High School Sports</a>													</span>
					</p>
				</footer>

				<p>Who is the top ALL-USA Boys Basketball PG of all-time? VOTE NOW! </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/baltimore-football-coach-no-longer-employed-while-police-investigate-allegation-of-physical-assault"
						title="Baltimore football coach &#039;no longer employed&#039; while police investigate allegation of physical assault"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/c6c-xj-u4aimvyk.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/c6c-xj-u4aimvyk.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Baltimore football coach &#039;no longer employed&#039; while police investigate allegation of physical assault" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='http://usatodayhss.com/2018/baltimore-football-coach-no-longer-employed-while-police-investigate-allegation-of-physical-assault';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://usatodayhss.com/2018/baltimore-football-coach-no-longer-employed-while-police-investigate-allegation-of-physical-assault"
			title="Baltimore football coach &#039;no longer employed&#039; while police investigate allegation of physical assault"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>13</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				3hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/baltimore-football-coach-no-longer-employed-while-police-investigate-allegation-of-physical-assault"
						title="Baltimore football coach &#039;no longer employed&#039; while police investigate allegation of physical assault"
						itemprop="url" 						>
							Baltimore football coach &#039;no longer employed&#039; while police investigate allegation of physical assault					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/camasmith" title="Posts by Cam Smith, USA TODAY High School Sports" class="author url fn" rel="author">Cam Smith, USA TODAY High School Sports</a>													</span>
					</p>
				</footer>

				<p>Sean Sandora had only been at Archbishop Curley for one season </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/girls-basketball-player-snoop-dogg-tweet"
						title="California girls basketball player kicked off team for retweeting Snoop Dogg"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2015/01/snoopdogg.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2015/01/snoopdogg.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="California girls basketball player kicked off team for retweeting Snoop Dogg" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='http://usatodayhss.com/2018/girls-basketball-player-snoop-dogg-tweet';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://usatodayhss.com/2018/girls-basketball-player-snoop-dogg-tweet"
			title="California girls basketball player kicked off team for retweeting Snoop Dogg"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>159</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				5hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/girls-basketball-player-snoop-dogg-tweet"
						title="California girls basketball player kicked off team for retweeting Snoop Dogg"
						itemprop="url" 						>
							California girls basketball player kicked off team for retweeting Snoop Dogg					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/camasmith" title="Posts by Cam Smith, USA TODAY High School Sports" class="author url fn" rel="author">Cam Smith, USA TODAY High School Sports</a>													</span>
					</p>
				</footer>

				<p>Racquel Alec is now suing for a violation of free speech </p>

				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/washington-basketball-coach-arrested-for-videotaping-students-changing"
						title="Washington basketball coach arrested for videotaping students changing"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/dvezesaumaiocru.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/dvezesaumaiocru.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Washington basketball coach arrested for videotaping students changing" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

											
<div class="meta" onclick="location.href='http://usatodayhss.com/2018/washington-basketball-coach-arrested-for-videotaping-students-changing';">
	<div class="reply-block">
		<a
			data-track="mostrecent"
			href="http://usatodayhss.com/2018/washington-basketball-coach-arrested-for-videotaping-students-changing"
			title="Washington basketball coach arrested for videotaping students changing"
			class="reply" rel="nofollow"
			>reply </a>
					<span class="share-text">
	<span class="social-count">
		<span>18</span>
		shares	</span>
</span>
			</div>
</div>
									</div>

			
			<div class="mobile-date">
				7hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/washington-basketball-coach-arrested-for-videotaping-students-changing"
						title="Washington basketball coach arrested for videotaping students changing"
						itemprop="url" 						>
							Washington basketball coach arrested for videotaping students changing					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/brian-price-king5" title="Posts by Brian Price, KING5" class="author url fn" rel="author">Brian Price, KING5</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	
		<article class="block big  " itemscope itemtype="http://schema.org/NewsArticle">

			
				<div class="img-holder none light">
					<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/miss-basketball-coach-leaves-role-to-start-orphanage-and-mission-in-uganda"
						title="Miss. basketball coach leaving role to start orphanage and mission in Uganda"
						class="link fixed-height-img-holder responsiveshort"
						rel="nofollow"
						style="background-image: url('https://usathss.files.wordpress.com/2018/02/du-w4qouqaawphu.jpg?w=192&#038;h=150&#038;crop=1');"
						itemprop="url"
						>

						
						
						<img src="https://usathss.files.wordpress.com/2018/02/du-w4qouqaawphu.jpg?w=192&#038;h=150&#038;crop=1" width="320" height="250" alt="Miss. basketball coach leaving role to start orphanage and mission in Uganda" itemprop="image">
						<span class="ie-overlay-hack"></span>

						
											</a>

									</div>

			
			<div class="mobile-date">
				9hr			</div>

			<div class="content  ">
				
				<h3>
										<a
						data-track="mostrecent"
						href="http://usatodayhss.com/2018/miss-basketball-coach-leaves-role-to-start-orphanage-and-mission-in-uganda"
						title="Miss. basketball coach leaving role to start orphanage and mission in Uganda"
						itemprop="url" 						>
							Miss. basketball coach leaving role to start orphanage and mission in Uganda					</a>
				</h3>

				
				
				<footer class="meta-info">
					<p>
												<span class="time">February 5, 2018 </span>
						<span class="dot">&middot;</span>
						<span class="author-links">
							<a href="http://usatodayhss.com/author/annie-costabile-the-clarion-ledger" title="Posts by Annie Costabile, The Clarion-Ledger" class="author url fn" rel="author">Annie Costabile, The Clarion-Ledger</a>													</span>
					</p>
				</footer>

				
				
				
			</div>
		</article>
	</div>
<a href="http://usatodayhss.com" class="article__back">More USA TODAY High School Sports</a>

		
	</div><!-- #content -->
</div><!-- #primary -->


<div id="secondary" class="widget-area container sidebar--follow" role="complementary">

	
	<aside id="sidebar-read-more" class="widget sidebar-upper">

		<div class="widget sidebar-ad top">
			<div id='acm-ad-tag-lawrence_dfp_desktop_top_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_top_300x250'); });</script></div>		</div>

		
		<div class="widget widget_usat_sidebar_top_posts_widget" id="usat_sidebar_top_posts_widget-2">		<div class="col1 right" id="sticky-sidebar">
				<div class="heading-small">
		<h2>MOST <span>POPULAR</span></h2>
	</div>
				
					<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathss.files.wordpress.com/2016/05/v0013571699-527458.jpg?w=474');" data-track="mostshared" href="http://usatodayhss.com/2016/tom-bradys-niece-making-her-own-name-on-the-softball-field-maya-brady" title="Tom Brady&#039;s niece Maya making her own name on the softball field" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathss.files.wordpress.com/2016/05/v0013571699-527458.jpg?w=100&#038;h=100&#038;crop=1" alt="Tom Brady&#039;s niece Maya making her own name on the softball field" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				18 May 16			</div>
			<div class="text-block">	
															 		<h2>
			 			<span>1.1k</span>
			 			 shares			 						 		</h2>
			 									<p><a data-track="mostshared" href="http://usatodayhss.com/2016/tom-bradys-niece-making-her-own-name-on-the-softball-field-maya-brady" title="Tom Brady&#039;s niece Maya making her own name on the softball field" itemprop="url" >Tom Brady's niece Maya making her own name on the softball field</a></p>
				<p class="widget-date">May 18, 2016</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathss.files.wordpress.com/2016/01/usp_nfl__philadelphia_eagles-press_conference_78985873.jpg?w=480');" data-track="mostshared" href="http://usatodayhss.com/2016/how-being-a-high-school-coach-started-doug-pederson-on-road-to-the-eagles" title="How being a high school coach started Doug Pederson on road to the Eagles" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathss.files.wordpress.com/2016/01/usp_nfl__philadelphia_eagles-press_conference_78985873.jpg?w=100&#038;h=100&#038;crop=1" alt="How being a high school coach started Doug Pederson on road to the Eagles" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				3w			</div>
			<div class="text-block">	
															 		<h2>
			 			<span>47</span>
			 			 shares			 						 		</h2>
			 									<p><a data-track="mostshared" href="http://usatodayhss.com/2016/how-being-a-high-school-coach-started-doug-pederson-on-road-to-the-eagles" title="How being a high school coach started Doug Pederson on road to the Eagles" itemprop="url" >How being a high school coach started Doug Pederson on road to the Eagles</a></p>
				<p class="widget-date">January 21, 2016</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathss.files.wordpress.com/2016/02/screen-shot-2016-02-08-at-12-25-35-am.jpg?w=301');" data-track="mostshared" href="http://usatodayhss.com/2017/7-footer-john-krahn-the-largest-man-in-football-finds-new-home-at-lincoln-university-mo" title="7-footer John Krahn, the largest man in football, finds new home at Lincoln University (Mo.)" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathss.files.wordpress.com/2016/02/screen-shot-2016-02-08-at-12-25-35-am.jpg?w=100&#038;h=100&#038;crop=1" alt="7-footer John Krahn, the largest man in football, finds new home at Lincoln University (Mo.)" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				2d			</div>
			<div class="text-block">	
															 		<h2>
			 			<span>1.6k</span>
			 			 shares			 						 		</h2>
			 									<p><a data-track="mostshared" href="http://usatodayhss.com/2017/7-footer-john-krahn-the-largest-man-in-football-finds-new-home-at-lincoln-university-mo" title="7-footer John Krahn, the largest man in football, finds new home at Lincoln University (Mo.)" itemprop="url" >7-footer John Krahn, the largest man in football, finds new home at Lincoln University (Mo.)</a></p>
				<p class="widget-date">February 3, 2017</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathss.files.wordpress.com/2018/02/636440198607709914-joe-girard-basketball.jpg?w=453');" data-track="mostshared" href="http://usatodayhss.com/2018/joe-girard-breaks-scoring-record" title="Joseph Girard breaks New York state basketball scoring record" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathss.files.wordpress.com/2018/02/636440198607709914-joe-girard-basketball.jpg?w=100&#038;h=100&#038;crop=1" alt="Joseph Girard breaks New York state basketball scoring record" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				4d			</div>
			<div class="text-block">	
															 		<h2>
			 			<span>286</span>
			 			 shares			 						 		</h2>
			 									<p><a data-track="mostshared" href="http://usatodayhss.com/2018/joe-girard-breaks-scoring-record" title="Joseph Girard breaks New York state basketball scoring record" itemprop="url" >Joseph Girard breaks New York state basketball scoring record</a></p>
				<p class="widget-date">February 1, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
				<article class="block standard-thumbnail" itemscope itemtype="http://schema.org/NewsArticle">
						<a style="background-image:url('https://usathss.files.wordpress.com/2018/02/presley-mug-web.jpg?w=480');" data-track="mostshared" href="http://usatodayhss.com/2018/ex-nfl-player-assistant-football-coach-in-s-c-charged-with-having-sex-with-student" title="Ex-NFL player, assistant football coach in S.C. charged with having sex with student" class="img-holder link light" rel="nofollow" itemprop="url">
				<img src="https://usathss.files.wordpress.com/2018/02/presley-mug-web.jpg?w=100&#038;h=100&#038;crop=1" alt="Ex-NFL player, assistant football coach in S.C. charged with having sex with student" itemprop="image">

								<span class="ie-overlay-hack"></span>
                                			</a>
						<div class="mobile-date">
				4d			</div>
			<div class="text-block">	
															 		<h2>
			 			<span>9.1k</span>
			 			 shares			 						 		</h2>
			 									<p><a data-track="mostshared" href="http://usatodayhss.com/2018/ex-nfl-player-assistant-football-coach-in-s-c-charged-with-having-sex-with-student" title="Ex-NFL player, assistant football coach in S.C. charged with having sex with student" itemprop="url" >Ex-NFL player, assistant football coach in S.C. charged with having sex with student</a></p>
				<p class="widget-date">February 1, 2018</p>
				<h2 class="widget-category">				</h2>
							</div>
		</article>
					
		</div>
		</div>
		<div class="widget sidebar-ad bottom">
			<div id='acm-ad-tag-lawrence_dfp_desktop_bottom_300x250' style='width:%width%px; height:%height%px;'><script type='text/javascript'>googletag.cmd.push(function() { googletag.display('acm-ad-tag-lawrence_dfp_desktop_bottom_300x250'); });</script></div>		</div>

		
<div id="footer-info">
	<p class="footer__logo">
		<a href="http://usatodaysports.com" rel="nofollow" target="_blank">
			<img src="https://usathss.files.wordpress.com/2017/04/logo-usat-footer.png" alt="USA Today Sports">
		</a>
	</p>

	<div class="togglee">
		<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-361339" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-361339"><a href="http://usatodayhss.com/feedback">Feedback</a></li>
<li id="menu-item-484945" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-484945"><a href="http://usatodayhss.com/privacy-noticeyour-california-privacy-rights">Privacy Notice/Your California Privacy Rights</a></li>
<li id="menu-item-484946" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-484946"><a href="http://usatodayhss.com/terms-of-service">Terms of Service</a></li>
<li id="menu-item-485217" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-485217"><a href="/privacy-noticeyour-california-privacy-rights/#adchoices">Ad Choices</a></li>
<li id="menu-item-766388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-766388"><a href="http://usatodayhss.com/frequently-asked-questions">Frequently Asked Questions</a></li>
<li id="menu-item-766389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-766389"><a href="http://usatodayhss.com/community-rules">Community Rules</a></li>
<li id="menu-item-766401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-766401"><a href="http://usatodayhss.com/poll-and-voting-rules">Poll and Voting Rules</a></li>
</ul></div>
		
		<p class="poweredby-wordpress">
			Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=usatodayhss.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>		</p>
	</div>

	<p class="toggler">
		<a href="#footer-toggle" rel="nofollow">
			More Information		</a>
		<span class="arrow-up"></span>
	</p>

	<script type="text/javascript">
		var footer_expand_text   = "More Information";
		var footer_collapse_text = "Less Information";
	</script>
</div>

	</aside>

	<div id="secondary-bottom"></div>

</div><!-- #secondary -->
<div style="clear:both;"></div>
			</div><!-- Site Main -->
		</div><!-- Wrapper Holder -->
	</div><!-- Wrapper -->

	
	<!-- wpcom_wp_footer -->
<div class="mobile-nav" id="mobile-nav-holder">
	<div class="mobile-nav__header">
					<img class="mobile-nav__logo" src="https://usathss.files.wordpress.com/2017/04/hss-icon.png" alt="USA TODAY High School Sports">
				<a class="mobile-nav__breadcrumb" href="http://usatodayhss.com">Home</a>
		<span class="mobile-nav__close"></span>
	</div>
		<ul class="mobile-nav__social ">
					<li class="mobile-nav__item mobile-nav__item--stalk">Follow us&hellip;</li>
							<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--facebook">
				<a href="https://www.facebook.com/USATODAYHSS/" class="mobile-nav__item-link"></a>
			</li>
					<li class="mobile-nav__item mobile-nav__item--social mobile-nav__item--twitter">
				<a href="https://twitter.com/usatodayhss" class="mobile-nav__item-link"></a>
			</li>
			</ul>
	<ul class="mobile-nav__menu">
		<li class="mobile-nav__item mobile-nav__item--home mobile-nav__item--parent"><a href="http://usatodayhss.com/">HOME</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--usa-today-high-school-sports"><a href="http://launch.usatodayhss.com/">USA TODAY High School Sports</a></li>
	<li class="mobile-nav__item mobile-nav__item--high-school-football-america"><a href="http://usatodayhss.com/category/high-school-football-america">High School Football America</a></li>
	<li class="mobile-nav__item mobile-nav__item--texas-hs-football"><a href="http://usatodayhss.com/category/texas-hs-football">Texas HS Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--florida-hs-football"><a href="http://usatodayhss.com/category/florida-hs-football">Florida HS Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--gridiron-new-jersey"><a href="http://usatodayhss.com/category/gridiron-new-jersey">Gridiron New Jersey</a></li>
	<li class="mobile-nav__item mobile-nav__item--prep-circuit"><a href="http://usatodayhss.com/category/prep-circuit">Prep Circuit</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--scores mobile-nav__item--parent"><a>Scores</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--national-basketball"><a href="http://usatodayhss.com/2016/scores-high-school-basketball-scores-around-the-nation">National - Basketball</a></li>
	<li class="mobile-nav__item mobile-nav__item--super-25-boys-basketball"><a href="http://usatodayhss.com/2016/scores-high-school-basketball-super-25-boys-basketball-scoreboard">Super 25 - Boys Basketball</a></li>
	<li class="mobile-nav__item mobile-nav__item--super-25-girls-basketball"><a href="http://usatodayhss.com/2016/scores-high-school-basketball-super-25-girls-basketball-scoreboard">Super 25 - Girls Basketball</a></li>
	<li class="mobile-nav__item mobile-nav__item--super-25-football"><a href="http://usatodayhss.com/2017/scores-super-25-football-2">Super 25 - Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--national-football"><a href="http://usatodayhss.com/2017/scores-live-in-game-football-scores-around-the-nation-as-they-happen">National - Football</a></li>
	<li class="mobile-nav__item mobile-nav__item--super-25-baseball"><a href="http://usatodayhss.com/2017/scores-super-25-baseball-2">Super 25 - Baseball</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--features mobile-nav__item--parent"><a>Features</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--mcdonalds-all-american-games"><a href="http://usatodayhss.com/category/mcdonalds-all-american-game">McDonald's All American Games</a></li>
	<li class="mobile-nav__item mobile-nav__item--score-predictor"><a href="http://usatodayhss.com/score-predictor">Score Predictor</a></li>
	<li class="mobile-nav__item mobile-nav__item--all-usa"><a href="http://usatodayhss.com/category/all-usa">ALL-USA</a></li>
	<li class="mobile-nav__item mobile-nav__item--super-25"><a href="http://usatodayhss.com/category/super-25">Super 25</a></li>
	<li class="mobile-nav__item mobile-nav__item--hoophall-classic"><a href="http://usatodayhss.com/category/hoophall-classic">Hoophall Classic</a></li>
	<li class="mobile-nav__item mobile-nav__item--u-s-army-all-american-bowl"><a href="http://usatodayhss.com/category/u-s-army-all-american-bowl">U.S. Army All-American Bowl</a></li>
	<li class="mobile-nav__item mobile-nav__item--under-armour-all-america-game"><a href="http://usatodayhss.com/category/under-armour-all-america-game">Under Armour All-America Game</a></li>
	<li class="mobile-nav__item mobile-nav__item--early-signing-period"><a href="http://usatodayhss.com/category/early-signing-period">Early Signing Period</a></li>
	<li class="mobile-nav__item mobile-nav__item--jordan-brand-classic"><a href="http://usatodayhss.com/category/jordan-brand-classic">Jordan Brand Classic</a></li>
	<li class="mobile-nav__item mobile-nav__item--national-signing-day"><a href="http://usatodayhss.com/category/signing-day">National Signing Day</a></li>
	<li class="mobile-nav__item mobile-nav__item--nata-sports-safety"><a href="http://usatodayhss.com/tag/nata">NATA Sports Safety</a></li>
	<li class="mobile-nav__item mobile-nav__item--achieving-the-dream"><a href="http://usatodayhss.com/category/video/achieving-the-dream/">Achieving The Dream</a></li>
	<li class="mobile-nav__item mobile-nav__item--spalding-hoophall-classic"><a href="http://usatodayhss.com/category/hoophall-classic">Spalding Hoophall Classic</a></li>
	<li class="mobile-nav__item mobile-nav__item--celeb-chop-up"><a href="http://usatodayhss.com/category/celeb-chop-up">Celeb Chop-Up</a></li>
	<li class="mobile-nav__item mobile-nav__item--athlete-look-back"><a href="http://usatodayhss.com/category/athlete-look-back">Athlete Look Back</a></li>
	<li class="mobile-nav__item mobile-nav__item--girls-sports-month"><a href="http://www.usatodayhss.com/category/girls-sports-month">Girls Sports Month</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--blogs mobile-nav__item--parent"><a>Blogs</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--mcdonalds-all-american-game-hometown-heroes"><a href="http://usatodayhss.com/category/mcdonalds-all-american-game-selection-tour">McDonald's All American Game Hometown Heroes</a></li>
	<li class="mobile-nav__item mobile-nav__item--under-armour-all-america-selection-tour"><a href="http://usatodayhss.com/category/under-armour-all-america-selection-tour">Under Armour All-America Selection Tour</a></li>
	<li class="mobile-nav__item mobile-nav__item--u-s-army-all-american-selection-tour"><a href="http://usatodayhss.com/category/u-s-army-all-american-bowl-selection-tour">U.S. Army All-American Selection Tour</a></li>
	<li class="mobile-nav__item mobile-nav__item--outside-the-box"><a href="http://usatodayhss.com/category/outside-the-box">Outside The Box</a></li>
	<li class="mobile-nav__item mobile-nav__item--recruiting"><a href="http://www.usatodayhss.com/tag/recruiting-2">Recruiting</a></li>
	<li class="mobile-nav__item mobile-nav__item--athlete-blogs"><a href="http://usatodayhss.com/category/athlete-blogs">Athlete Blogs</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--rankings mobile-nav__item--parent"><a>Rankings</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--boys-basketball-expert"><a href="http://usatodayhss.com/rankings/expert/boys/basketball/2017/10">Boys Basketball - Expert</a></li>
	<li class="mobile-nav__item mobile-nav__item--boys-basketball-computer"><a href="http://usatodayhss.com/rankings/computer/boys/basketball/US/2017">Boys Basketball - Computer</a></li>
	<li class="mobile-nav__item mobile-nav__item--girls-basketball-expert"><a href="http://usatodayhss.com/rankings/expert/girls/basketball/2017/9">Girls Basketball - Expert</a></li>
	<li class="mobile-nav__item mobile-nav__item--girls-basketball-computer"><a href="http://usatodayhss.com/rankings/computer/girls/basketball/US/2017">Girls Basketball - Computer</a></li>
	<li class="mobile-nav__item mobile-nav__item--wrestling"><a href="http://usatodayhss.com/rankings/expert/boys/wrestling/2017/4">Wrestling</a></li>
	<li class="mobile-nav__item mobile-nav__item--boys-soccer-winter"><a href="http://usatodayhss.com/rankings/expert/boys/winter-soccer/2017/3">Boys Soccer - Winter</a></li>
	<li class="mobile-nav__item mobile-nav__item--girls-soccer-winter"><a href="http://usatodayhss.com/rankings/expert/girls/winter-soccer/2017/3">Girls Soccer - Winter</a></li>
	<li class="mobile-nav__item mobile-nav__item--football-expert"><a href="http://usatodayhss.com/rankings/expert/boys/football/2017/20">Football - Expert</a></li>
	<li class="mobile-nav__item mobile-nav__item--football-computer"><a href="http://usatodayhss.com/rankings/computer/boys/football/US/2017">Football - Computer</a></li>
	<li class="mobile-nav__item mobile-nav__item--boys-soccer-fall"><a href="http://usatodayhss.com/rankings/expert/boys/fall-soccer/2017/14">Boys Soccer - Fall</a></li>
	<li class="mobile-nav__item mobile-nav__item--girls-soccer-fall"><a href="http://usatodayhss.com/rankings/expert/girls/fall-soccer/2017/14">Girls Soccer - Fall</a></li>
	<li class="mobile-nav__item mobile-nav__item--girls-volleyball"><a href="http://usatodayhss.com/rankings/expert/girls/volleyball/2017/12">Girls Volleyball</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--video-photos mobile-nav__item--parent"><a href="#">Video/Photos</a>
<ul class="sub-menu">
	<li class="mobile-nav__item mobile-nav__item--video"><a href="http://usatodayhss.com/category/video">Video</a></li>
	<li class="mobile-nav__item mobile-nav__item--photos"><a href="http://usatodayhss.com/category/photos">Photos</a></li>
</ul>
</li>
<li class="mobile-nav__item mobile-nav__item--polls"><a href="http://usatodayhss.com/category/polls">Polls</a></li>
<li class="mobile-nav__item mobile-nav__item--store"><a href="http://spiritshop.com/hssschoolsearch.aspx?utm_source=hss&#038;utm_medium=partner&#038;utm_campaign=hss-nav&#038;utm_term=header_nav_link">Store</a></li>
	</ul>
	<ul class="mobile-nav__footer-menu">
		<li id="menu-item-361339" class="mobile-nav__item mobile-nav__item--feedback"><a href="http://usatodayhss.com/feedback">Feedback</a></li>
<li id="menu-item-484945" class="mobile-nav__item mobile-nav__item--privacy-notice-your-california-privacy-rights"><a href="http://usatodayhss.com/privacy-noticeyour-california-privacy-rights">Privacy Notice/Your California Privacy Rights</a></li>
<li id="menu-item-484946" class="mobile-nav__item mobile-nav__item--terms-of-service"><a href="http://usatodayhss.com/terms-of-service">Terms of Service</a></li>
<li id="menu-item-485217" class="mobile-nav__item mobile-nav__item--ad-choices"><a href="/privacy-noticeyour-california-privacy-rights/#adchoices">Ad Choices</a></li>
<li id="menu-item-766388" class="mobile-nav__item mobile-nav__item--frequently-asked-questions"><a href="http://usatodayhss.com/frequently-asked-questions">Frequently Asked Questions</a></li>
<li id="menu-item-766389" class="mobile-nav__item mobile-nav__item--community-rules"><a href="http://usatodayhss.com/community-rules">Community Rules</a></li>
<li id="menu-item-766401" class="mobile-nav__item mobile-nav__item--poll-and-voting-rules"><a href="http://usatodayhss.com/poll-and-voting-rules">Poll and Voting Rules</a></li>

		
					<li class="mobile-nav__item mobile-nav__item--vipcom">
				Powered by <a href="https://vip.wordpress.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=usatodayhss.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a>			</li>
			</ul>

			<a
			class="mobile-nav__footer"
			href="http://usatodaysports.com"
			target="_blank"
			title="USA Today Sports"
			rel="nofollow"
		>
			<img class="mobile-nav__footer-image" src="https://usathss.files.wordpress.com/2017/04/usat-logo-mobile-off-canvas.png">
		</a>
	</div>
<div id="main_ad" style="height:1px; width:1px; overflow:auto;position: absolute;left: -999em;"><!--AD UNIT 4--></div><script type='text/javascript' src='//0.gravatar.com/js/gprofiles.js?ver=201806y'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/gravatar-hovercards/wpgroho.js?m=1380573781h'></script>

	<script>
		//initialize and attach hovercards to all gravatars
		jQuery( document ).ready( function( $ ) {

			if (typeof Gravatar === "undefined"){
				return;
			}

			if ( typeof Gravatar.init !== "function" ) {
				return;
			}			

			Gravatar.profile_cb = function( hash, id ) {
				WPGroHo.syncProfileData( hash, id );
			};
			Gravatar.my_hash = WPGroHo.my_hash;
			Gravatar.init( 'body', '#wp-admin-bar-my-account' );
		});
	</script>

		<div style="display:none">
	</div>
<script type='text/javascript' src='https://s0.wp.com/_static/??/wp-content/js/devicepx.js,/wp-content/mu-plugins/likes/queuehandler.js?m=1508795041j'></script>
<script type='text/javascript' src='https://native.sharethrough.com/assets/sfp.js?ver=1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var stickyInlineVideosOptions = {"side":"right"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var _LAWRENCE_MAIN_EXPORTS = {"right_rail_ad_delay":{"distance":"2000","seconds":"10","active":"1"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcomVipAnalytics = {"is_404":"0","is_home":"0","is_single":"1","is_front_page":"0","is_archive":"0","percentToTrack":"1"};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiFacebookReferral = "0";
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wasabiAdFollowOptions = {"headerAdPosition":"0","enable":"1","maxDistance":"1300","medAdHeight":"239","maxDistanceMed":"600","largeAdHeight":"400","maxDistanceLarge":"0","isDesktop":"1","headerHeight":"60"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJydkd1qwzAMhV9orvtDGL0YexbFEZ0cW84sOVnefs5gW6GFNrkTQufjHB07DcYlVmS1+oERxY402CKgqYPZDKFciMWKkutnQxyI0YzUYRLr7+93Xl7sA26AKSM7XBiBWus/C+Z551LqCdcCIhCv1ShCoBINftVzocQ3tmP5S380C8f/4AwwhLnGfirnL2ECgZYWRFEKG6UMI11Aq9lteqn1tJC3iSHXzOGpbm7F9xq6+i90kdhUa/VQFHOdTBox52pY/ncrCZrB9cur3+PboTm8nprjvjn7b3h7HUc='></script>
<script type='text/javascript' src='https://platform-api.sharethis.com/js/sharethis.js#product=sop-wordpress-plugin'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'65907669','blog_tz':'-5','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'65907669','v':'wpcom','tz':'-5','user_id':'0','post':'101308543','subd':'usathss'}]);
function st_vt() {var x=document.createElement("img");x.src="http://pixel.wp.com/g.gif?blog=65907669&v=wpcomvt&tz=-5&user_id=0&post=101308543&subd=usathss&rand="+Math.random();}
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1BNmNJfGhxNCVxUDExYmtib2E/SzdEJm0lUEtbdFU0fFk4cHZvcUFrZT90Tn4yQm1+R3NyNTcvN1dHVE8tU1Y5Tk5xJUNPdGUvNWlURCVDWHdySjhHMEF6azhRa2xxSC5tLj1TNUl6JTFUMz9jVlo0YXJWRSw1X20lbWdMK1RDZCwtY3ZGMCxlbWZsWUhDLDFkQyVMaEZjJV13JithMFswcFhXW21yM1pCS3lSXWUwQzksVSZDJXFiVjVMMTFmSH5WdEdbWGUmejgvUENBOCU/ZGdjYWxiM0gtJnNMW09qVk91LHk/emc0YnREZDg2eUpaR1Q1V01MRVdSKzI='}]);
_stq.push([ 'clickTrackerInit', '65907669', '101308543' ]);
	</script>
<noscript><img src="http://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>


<!--
$$\
$$ |
$$ |      $$$$$$\  $$\  $$\  $$\  $$$$$$\   $$$$$$\  $$$$$$$\   $$$$$$$\  $$$$$$\
$$ |      \____$$\ $$ | $$ | $$ |$$  __$$\ $$  __$$\ $$  __$$\ $$  _____|$$  __$$\
$$ |      $$$$$$$ |$$ | $$ | $$ |$$ |  \__|$$$$$$$$ |$$ |  $$ |$$ /      $$$$$$$$ |
$$ |     $$  __$$ |$$ | $$ | $$ |$$ |      $$   ____|$$ |  $$ |$$ |      $$   ____|
$$$$$$$$\$$$$$$$ |\$$$$$\$$$$  |$$ |      \$$$$$$$\ $$ |  $$ |\$$$$$$$\ \$$$$$$$\
\________|\_______| \_____\____/ \__|       \_______|\__|  \__| \_______| \_______|

Brought to you by your good friends at USA Today Sports.
-->
<!--
	generated in 0.259 seconds
	104236 bytes batcached for 300 seconds
-->
